Can't install or upgrade pip for the life of me

I recognise this is an amateur question but it's true, i really can't. I need to be able to use pip, and as i downloaded python 3.6.1 from the official site apparently i already have it. So i try to upgrade it, and get "Python is not recognised as a function" and I've done

setx PATH Python36

and it said it's successful but it still won't recognise python.

Please help! I really need pip to install some modules

1 answer

  • answered 2017-08-12 09:40 user8387659

    If you can't use pip to upgrade, trying manual installing.

    Step 1. Remove or reinstall python

    Step 2 If you use windows os i think u refresh install

    Step 3 Recognize the command and keep success