sklearn.linear_model causing ImportError when opening .exe created with PyInstaller

this is my first post to stackoverflow, though I've been utilizing this site for a good long while now. Excited to be in the community.

(I'm fairly new to python, and especially to PyInstaller) I'm developing a data exploration GUI based on tkinter that relies heavily on pandas and numpy and also utilizes the sklearn.linear_model module. I've got a venv setup and I'm able to run PyInstaller and successfully create an .exe. However, when I try to open the program (via command line) it throws:

"ImportError: DLL load failed: The specified module could not be found."

The error occurs on the line import sklearn.linear_model as lin in the script. I tried creating a hook for the module with contents hiddenimports = ['sklearn.linear_model'] to no avail, and have been digging across the internet for hours and can't seem to find an answer.

If I comment out the import, the PyInstaller continues to work just fine, and the .exe works--the program opens just fine, but of course functionality related to the linear model is not available. So it seems I've narrowed it down to the module, but of course, what to do next? No clue.

Here's the traceback:

(venv_py35) C:\Users\ts012096\Desktop\Python\ToolBox\Draft01>dist\CrashDET_draft
01\CrashDET_draft01.exe
Traceback (most recent call last):
  File "CrashDET_draft01.py", line 28, in <module>
    import sklearn.linear_model as lin
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 631, in exec_module
    exec(bytecode, module.__dict__)
  File "lib\site-packages\sklearn\__init__.py", line 134, in <module>
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 631, in exec_module
    exec(bytecode, module.__dict__)
  File "lib\site-packages\sklearn\base.py", line 13, in <module>
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 631, in exec_module
    exec(bytecode, module.__dict__)
  File "lib\site-packages\sklearn\utils\__init__.py", line 11, in <module>
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 631, in exec_module
    exec(bytecode, module.__dict__)
  File "lib\site-packages\sklearn\utils\validation.py", line 18, in <module>
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 631, in exec_module
    exec(bytecode, module.__dict__)
  File "lib\site-packages\sklearn\utils\fixes.py", line 144, in <module>
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 631, in exec_module
    exec(bytecode, module.__dict__)
  File "lib\site-packages\scipy\sparse\linalg\__init__.py", line 114, in <module
>
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 631, in exec_module
    exec(bytecode, module.__dict__)
  File "lib\site-packages\scipy\sparse\linalg\isolve\__init__.py", line 6, in <m
odule>
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 631, in exec_module
    exec(bytecode, module.__dict__)
  File "lib\site-packages\scipy\sparse\linalg\isolve\iterative.py", line 7, in <
module>
  File "c:\users\ts012096\desktop\python\toolbox\draft02\venv_py35\lib\site-pack
ages\PyInstaller\loader\pyimod03_importers.py", line 714, in load_module
    module = loader.load_module(fullname)
ImportError: DLL load failed: The specified module could not be found.
[46628] Failed to execute script CrashDET_draft01

Would love to learn your insights on this. Thanks!

Python v3.5.3 PyInstaller 3.4.dev0+5f9190544 sklearn version 0.19.1 All modules should be up to date.