Adding the DragDropContext gives me an error about exporting the ES6 module

So I started to integrate the react dnd library into my application, and the first thing I tried to do is add the DragDropContext with the Html5 backend.

When I add the attribute to the class I get this error:

Uncaught Error: Expected the backend to be a function or an ES6 module exporting a default function.

import React from 'react';
import Link from 'react-router-dom';
import { connect } from 'react-redux';
import { DragDropContext } from 'react-dnd';
import { HTML5Backend } from 'react-dnd-html5-backend';
import PropTypes from 'prop-types';

@DragDropContext(HTML5Backend)
class UserHowView extends React.Component {
  ...
  ..
}


const mapStateToProps = state => ({
 ...
});


export default connect(mapStateToProps)(userShowView);

What am I doing wrong so far?

One of the examples for the library has this:

@DragDropContext(HTML5Backend)
export default class Container extends Component {

But my definition and export are separate.