Can't install twitteR package in R

I'm trying to install the mentioned package, but in the middle of the process the following message shown and the installation fails.

package ‘rjson’ successfully unpacked and MD5 sums checked
Error in read.dcf(file.path(pkgname, "DESCRIPTION"), c("Package", "Type")) : 
  cannot open the connection
In addition: Warning messages:
1: In download.file(url, destfile, method, mode = "wb", ...) :
  downloaded length 745472 != reported length 769130
2: In unzip(zipname, exdir = dest) : error 1 in extracting from zip file
3: In read.dcf(file.path(pkgname, "DESCRIPTION"), c("Package", "Type")) :
  cannot open compressed file 'DBI/DESCRIPTION', probable reason 'No such file or directory'

The solution provided here couldn't help, by the way!

1 answer

  • answered 2018-04-14 16:11 42-

    You have not shown us "HOW" you tried installing pkg-twitteR but from the fact that it tried to install an additional package, I'm guessing you used dependencies=TRUE in the install.packages-command. (I pretty much always use that parameter, so i'm not criticizing that strategy.) In any case you should now (and always) edit your question to include the exact command or actions you used. You should also include details of your OS and R versions. The missing item appears to be in the "DBI"-package, so I would try:

    install.packages("DBI", dependencies=TRUE)
    

    And then retry to install. The installation process sometimes fails when dependencies of dependencies are not met.