latest open SSL doesn't use tls?

I have error like this

$ curl https://packagist.jp/packages.json
curl: (35) error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

At first I think this is because of obsolete SSL version.

However I updated openssl to latest one already.

$ openssl version
OpenSSL 1.0.2l  25 May 2017

However even I use option for tls version but it shows the same error.

$ curl https://packagist.jp/packages.json --tlsv1.0
curl: (35) error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

$ curl https://packagist.jp/packages.json --tlsv1.1
curl: (35) Unsupported SSL protocol version

$ curl https://packagist.jp/packages.json --tlsv1.2
curl: (35) Unsupported SSL protocol version