python package version incompatibility even on virtualenv

I am trying to install cuckoo sandbox(malware analysis tool).

I am doing pip install -U cuckoo as stated in cuckoo documentation, but it gives me following error

pandas 0.23.3 has requirement python-dateutil>=2.5.0, but you'll have python-dateutil 2.4.2 which is incompatible

So I thought maybe there is some package named python-dateutil and pandas is using its some version which is >= 2.5.0 but cuckoo needs its 2.4.2 version, so to not cause instability it's not getting installed.

So I thought of creating a virtualenv venv and install cuckoo in that. As there are no pandas in venv/lib/python2.7/site-packages installing a previous version of python-dateutil shouldn't be a problem. But again I am getting the same error. I am not getting where is the problem.