Laravel FatalErrorException but code seems ok

I'm dealing with laravel 5.0 throwing a FatalErrorException with no useful description.

We have a web app developed in laravel 5.0, with a small part in angularJS, and I work on an macbook air 2015.

A branch of the git project doesn't seem to work on my machine, although the other branches work just fine, and there's been no changes in configuration and no big changes in the code either. Also, it works on my colleague's machine.

Here's the returned error message:

local.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: 
Uncaught TypeError: Argument 1 passed to App\Exceptions\Handler::report() must be an instance of Exception, 
instance of ParseError given, called in Applications/XAMPP/htdocs/myApp/vendor/laravel/framework/src/Illuminate/Foundation/Bootstrap/HandleExceptions.php on line 73 and defined in /Applications/XAMPP/htdocs/myApp/app/Exceptions/Handler.php:36

Here's Handler.php

use Exception;
use Illuminate\Database\Eloquent\ModelNotFoundException;
use Illuminate\Foundation\Exceptions\Handler as ExceptionHandler;


use Tymon\JWTAuth\Exceptions\JWTException;

use Tymon\JWTAuth\Exceptions\TokenExpiredException;
use Tymon\JWTAuth\Exceptions\TokenInvalidException;
use Tymon\JWTAuth\Exceptions\TokenBlacklistedException;

use Flash;
use Response;

class Handler extends ExceptionHandler {

    /**
     * A list of the exception types that should not be reported.
     *
     * @var array
     */
    protected $dontReport = [
        'Symfony\Component\HttpKernel\Exception\HttpException'
    ];

    /**
     * Report or log an exception.
     *
     * This is a great spot to send exceptions to Sentry, Bugsnag, etc.
     *
     * @param  \Exception  $e
     * @return void
     */
    public function report(Exception $e)
    {
        parent::report($e);
    }

    /**
     * Render an exception into an HTTP response.
     *
     * @param  \Illuminate\Http\Request  $request
     * @param  \Exception  $e
     * @return \Illuminate\Http\Response
     */
    public function render($request, Exception $e)
    {
        if ($e instanceof ModelNotFoundException) {
            if ($request->ajax()) {
                return Response::json(null, 403);
            }
            $modelName = str_replace("No query results for model [App\Models\\", "", $e->getMessage());
            $modelName = str_replace("].", "", $modelName);
            Flash::error(trans(lcfirst($modelName) . '.not_found'));
            return redirect()->back();
        }
        if ($e instanceof TokenBlacklistedException) {
        return response()->json(['error' => 'token_blacklisted', 'description' => 'descrizione errore token blacklisted'], $e->    getStatusCode());
        }
        if ($e instanceof TokenInvalidException) {
        return response()->json(['error' => 'token_invalid', 'description' => 'descrizione errore token invalid'], $e->getStatusCode())    ;
        }
        if ($e instanceof TokenExpiredException) {
        return response()->json(['error' => 'token_expired', 'description' => 'descrizione errore token expired'], $e->getStatusCode())    ;
        }
        if ($this->isHttpException($e)) {
            return $this->renderHttpException($e);
        }

        return parent::render($request, $e);
/*
        if ($this->isHttpException($e))
        {
            return $this->renderHttpException($e);
        }
        else
        {
            return parent::render($request, $e);
        }
*/
    }

}

I'm used at seeing this type of generic message whenever I forget an import, but this doesn't seem to be case. I suspect I'm missing something in the configuration.

The error occurs on every page but the login page and the part in angular.

As soon as I log in and I get redirected to the homepage it crashes.

Any help would be appreciated.