IOS POD INSTALLING ISSUE while trying to make connection using socket io client swift

I'm trying to install pod Socket.IO-Client-Swift, but it installs another pod with it and I get an error in CoomnCrypto in Starscream pod.

Here are the screens for what happen with me and the steps for installing pods

THIS SHOWS HOW I AM INSTALLING PODS enter image description here

THIS SHOWS THE ERRORS WHEN I BUILD THE PODS IN WORK SPACE enter image description here

i am using Using Swift 4 and xcode 9.4