What is the best way to create user defined roles and apply ACL dynamically on controllers in Sail.js?
What is the best way to create user defined roles and apply ACL dynamically on controllers in Sail.js ?
See also questions close to this topic
sailsjs v1.0 PATCH and PUT results in incorrect redirect
Working on a SailsJs 1.0 blueprint based REST API. Using both PUT and PATCH to attempt record update.
Record updated appears successful, however SailsJs is issuing 302 redirect on receipt of PUT or PATCH which goes nowhere and is subsequently terminated by a 404 error.
<- GET /manufacturer/5d28a29de8db6700079bf06f (8ms 200) debug: Using `PUT` to update a record is deprecated in Sails 1.0. Use `PATCH` instead! <- PUT /manufacturer/5d28a29de8db6700079bf06f (5ms 302) <- PUT /manufacturer/Manufacturer/show/5d28a29de8db6700079bf06f (1ms 404) <- GET /manufacturer (7ms 200)
Can anyone shed any light on what is happening here?
sails -v => 1.2.3
Front end is Angular8.1.1, node 12.6.0
Transpile JS in EJS templates to work with Internet Explorer
For example, in component:
<custom-component v-on:update="(newVal) => updateFunction(newVal)" ></custom-component>
the arrow function doesn't work on IE11. Can the grunt file be modified so that it includes the templates in transpiling?
Sails.js 1.1.0 Security issue: Upgrade lodash to version 4.17.13 or later
I created a new project using Sails.js and when I pushed it to github I am getting a security alert: Upgrade lodash to version 4.17.13 or later Problem is I can't seem to upgrade the lodash version. Sails is using
"@sailshq/lodash": "^3.10.3"I tried
yarn install email@example.com the yarn.lock still have the old version.
Anybody knows how to upgrade the lodash version?
Here is the full alert: CVE-2019-10744 high severity
Vulnerable versions: < 4.17.13 Patched version: 4.17.13 Affected versions of lodash are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.