Error: qt@5.5: unknown version :mountain_lion

Followed this tutorial in installing qt5.5 on a macOS version 10.13.6 High Sierra. Failed when trying to brew install qt@5.5 giving me an error below:

Error: qt@5.5: unknown version :mountain_lion

Versions:

  • brew
    Homebrew 2.0.0
    Homebrew/homebrew-core (git revision 175af; last commit 2019-02-02)
    Homebrew/homebrew-cask (git revision 05a81; last commit 2019-02-02)

  • macOS version 10.13.6 High Sierra

any help?

1 answer

  • answered 2019-02-03 04:16 houdinisparks

    turns out line 25 of qt@5.5.rb formula file checked out in the command ( as seen in the referred tutorial)

    git checkout 9ba3d6ef8891e5c15dbdc9333f857b13711d4e97 Formula/qt@5.5.rb
    

    is causing this problem. commenting it out fixes the issue

    enter image description here