Version of dart used in my existing project

I have a flutter project. I want to know what version of dart language is used in development of the project. And i also want to know the version of flutter framework which is used for developing the project. Is there any way to know these details? I do not have documentation of the project.

I tried flutter doctor command but it gives current version of dart and flutter framework installed in my android studio.

1 answer

  • answered 2019-05-21 08:34 Sami Kanafani

    in the pubspec.yaml, you will find the following

    environment:
      sdk: ">=2.1.0 <3.0.0"
    

    this indicates that this project works with dart 2.1.0 and above

    learn more here if you like