gitlab server timeout after configuring custom port

I have successfully installed gitlab and run it with embedded nginx. I have also successfully activated https. But when I try to change the external Url port (in both modes http and https) I get a time out error in my browser.

For information, I am running gitlab on a remote Ubuntu 18.04.2 server available from a registered domain and browsing with both Chrome and Safari from my computer from home.

I have reconfigured gitlab already a hundred times. I have checked the different involved ports to make sure they are allowed by firewall and listened to by the expected processes. Everything looks fine to me.

In /etc/gitlab/gitlab.rb I have done what described on the gitlab website for custom ports:

external_url 'http://gitlab.mydomain.com:10443'
...
nginx['enable'] = true

When on standard port 80 and 443 I get the access logs in /var/log/gitlab/nginx/gitlab_access.log. But as soon as I have added the custom port I don't see anything anymore.

Result of the 'ufw status verbose' cmd:

Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To                         Action      From
--                         ------      ----
...               
8080/tcp                   ALLOW IN    Anywhere                
10443/tcp                  ALLOW IN    Anywhere         
...         
8080/tcp (v6)              ALLOW IN    Anywhere (v6)             
10443/tcp (v6)             ALLOW IN    Anywhere (v6)

Result of the 'netstat -tulpn' cmd:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name 
tcp        0      0 127.0.0.1:8080          0.0.0.0:*               LISTEN      14865/unicorn maste
tcp        0      0 0.0.0.0:10443           0.0.0.0:*               LISTEN      21422/nginx: master 
tcp        0      0 0.0.0.0:8060            0.0.0.0:*               LISTEN      21422/nginx: master 

What is even weird is that when I perform cmd 'nc -vz gitlab.mydomain.com 10443', it succeeds:

Connection to gitlab.mydomain.com 10443 port [tcp/*] succeeded!

The request to http://gitlab.mydomain.com:10443 (or its SSL version when activated) ends up with a ERR_CONNECTION_TIMED_OUT on Chrome and 'Safari can't open the page "gitlab.mydomain.com:10443" because the server where this page is located isn't responding' on Safari.

Please help.