How to fix "nested code is modified or invalid" when signing for the Mac App Store?

I'm trying to sign an OSX app, build with Unity 2018.4.0. Usually the following commands did it:

chmod -R a+xr "Some.app"  
codesign -f -s '3rd Party Mac Developer Application: HolyCrapple' "Some.app/Contents/Plugins/unitypurchasing.bundle" 
codesign -f -s '3rd Party Mac Developer Application: HolyCrapple' --entitlements "Some.entitlements" "Some.app" --deep

Now, all out of a sudden, something seems to be broken. Calling

codesign --verify --verbose=4 "Some.app"

Prints:

Some.app: nested code is modified or invalid
file modified: /Some.app/Contents/Frameworks/MonoBleedingEdge/MonoEmbedRuntime/osx/libMonoPosixHelper.dylib
file modified: /Some.app/Contents/Frameworks/libssl.dylib
file modified: /Some.app/Contents/Frameworks/MonoBleedingEdge/MonoEmbedRuntime/osx/libmonobdwgc-2.0.dylib
file modified: /Some.app/Contents/Frameworks/libcrypto.dylib
file modified: /Some.app/Contents/Frameworks/UnityPlayer.dylib

Do you have any ideas what could cause this issue or how to fix it? Last time the app was updated (earlier this year using Unity 2018.3.01f1) it worked perfectly. Any advise is appreciated, Thank you.