Docker command causes error "The repository xxx" does not have a release file

To be honest, I am new to Docker and I need to run a Dockerfile but it results in this error. The error happens when docker is running the third line in Docker file. I ran docker build piquelab-webapp command and encountered this error.

I included my full docker file.

FROM php:7.0-apache

RUN apt-get update && apt-get install -y wget libxrender1 libfontconfig1 libmemcached-dev libz-dev libxml2-dev \
libmcrypt-dev mcrypt openssl zip unzip git libfreetype6-dev libjpeg62-turbo-dev libmcrypt-dev libpng-dev libssl-dev net-tools

RUN docker-php-ext-install -j$(nproc) pdo pdo_mysql mcrypt mysqli mbstring xml tokenizer \
    && docker-php-ext-configure gd --with-freetype-dir=/usr/include/ --with-jpeg-dir=/usr/include/ \
    && docker-php-ext-install -j$(nproc) gd

RUN pecl install memcached

RUN docker-php-ext-enable memcached

RUN a2enmod rewrite

RUN a2enmod ssl

RUN rm -r /var/lib/apt/lists/*

COPY docker/php/php.ini /usr/local/etc/php/
COPY docker/apache/000-default.conf /etc/apache2/sites-available/
COPY docker/apache/default-ssl.conf /etc/apache2/sites-available/
COPY docker/apache/servername.conf /etc/apache2/conf-available/

COPY . /var/www/html/


RUN a2enconf servername

#RUN a2ensite default-ssl

#RUN wget https://github.com/wkhtmltopdf/wkhtmltopdf/releases/download/0.12.4/wkhtmltox-0.12.4_linux-generic-amd64.tar.xz
#RUN tar -xvf wkhtmltox-0.12.4_linux-generic-amd64.tar.xz && cd wkhtmltox/bin/ && mv wkhtmltopdf /usr/local/bin/wkhtmltopdf && mv wkhtmltoimage  /usr/local/bin/wkhtmltoimage

RUN mv /var/www/html/docker/wkhtmltopdf/wkhtmltox/bin/wkhtmltopdf /usr/local/bin/wkhtmltopdf && mv /var/www/html/docker/wkhtmltopdf/wkhtmltox/bin/wkhtmltoimage  /usr/local/bin/wkhtmltoimage

#ENV STUNNEL_VERSION 4.56
#
#RUN wget -O - ftp://ftp.stunnel.org/stunnel/archive/4.x/stunnel-$STUNNEL_VERSION.tar.gz | tar -C /usr/local/src -zxv
#
#COPY ./docker/stunnel/stunnel.conf /etc/stunnel/
#
#RUN cd /usr/local/src/stunnel-$STUNNEL_VERSION && ./configure && make && make install
#
#CMD ["/etc/init.d/stunnel4", "start"]

EXPOSE 80
EXPOSE 443

Here is the error I get.

Step 3/18 : RUN apt-get update && apt-get install -y wget libxrender1 libfontconfig1 libmemcached-dev libz-dev libxml2-dev libmcrypt-dev mcrypt openssl zip unzip git libfreetype6-dev libjpeg62-turbo-dev libmcrypt-dev libpng12-dev libssl1.0.0 net-tools
 ---> Running in ad2ec615cf2e
Ign:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://security.debian.org/debian-security stretch/updates Release
Ign:3 http://security.debian.org/debian-security stretch/updates/main all Packages
Ign:4 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
Ign:3 http://security.debian.org/debian-security stretch/updates/main all Packages
Ign:4 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
Ign:3 http://security.debian.org/debian-security stretch/updates/main all Packages
Ign:4 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
Ign:3 http://security.debian.org/debian-security stretch/updates/main all Packages
Ign:4 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
Ign:3 http://security.debian.org/debian-security stretch/updates/main all Packages
Ign:4 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
Ign:3 http://security.debian.org/debian-security stretch/updates/main all Packages
Err:4 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
  Cannot initiate the connection to security.debian.org:80 (0.0.9.198). - connect (22: Invalid argument)
Ign:5 http://deb.debian.org/debian stretch InRelease
Ign:6 http://deb.debian.org/debian stretch-updates InRelease
Ign:7 http://deb.debian.org/debian stretch Release
Ign:8 http://deb.debian.org/debian stretch-updates Release
Ign:9 http://deb.debian.org/debian stretch/main amd64 Packages
Ign:10 http://deb.debian.org/debian stretch/main all Packages
Ign:11 http://deb.debian.org/debian stretch-updates/main all Packages
Ign:12 http://deb.debian.org/debian stretch-updates/main amd64 Packages
Ign:9 http://deb.debian.org/debian stretch/main amd64 Packages
Ign:10 http://deb.debian.org/debian stretch/main all Packages
Ign:11 http://deb.debian.org/debian stretch-updates/main all Packages
Ign:12 http://deb.debian.org/debian stretch-updates/main amd64 Packages
Ign:9 http://deb.debian.org/debian stretch/main amd64 Packages
Ign:10 http://deb.debian.org/debian stretch/main all Packages
Ign:11 http://deb.debian.org/debian stretch-updates/main all Packages
Ign:12 http://deb.debian.org/debian stretch-updates/main amd64 Packages
Ign:9 http://deb.debian.org/debian stretch/main amd64 Packages
Ign:10 http://deb.debian.org/debian stretch/main all Packages
Ign:11 http://deb.debian.org/debian stretch-updates/main all Packages
Ign:12 http://deb.debian.org/debian stretch-updates/main amd64 Packages
Ign:9 http://deb.debian.org/debian stretch/main amd64 Packages
Ign:10 http://deb.debian.org/debian stretch/main all Packages
Ign:11 http://deb.debian.org/debian stretch-updates/main all Packages
Ign:12 http://deb.debian.org/debian stretch-updates/main amd64 Packages
Err:9 http://deb.debian.org/debian stretch/main amd64 Packages
  Cannot initiate the connection to deb.debian.org:80 (0.0.9.199). - connect (22: Invalid argument)
Ign:10 http://deb.debian.org/debian stretch/main all Packages
Ign:11 http://deb.debian.org/debian stretch-updates/main all Packages
Err:12 http://deb.debian.org/debian stretch-updates/main amd64 Packages
  Cannot initiate the connection to deb.debian.org:80 (0.0.9.199). - connect (22: Invalid argument)
Reading package lists...
W: The repository 'http://security.debian.org/debian-security stretch/updates Release' does not have a Release file.
W: The repository 'http://deb.debian.org/debian stretch Release' does not have a Release file.
W: The repository 'http://deb.debian.org/debian stretch-updates Release' does not have a Release file.
E: Failed to fetch http://security.debian.org/debian-security/dists/stretch/updates/main/binary-amd64/Packages  Cannot initiate the connection to security.debian.org:80 (0.0.9.198). - connect (22: Invalid argument)
E: Failed to fetch http://deb.debian.org/debian/dists/stretch/main/binary-amd64/Packages  Cannot initiate the connection to deb.debian.org:80 (0.0.9.199). - connect (22: Invalid argument)
E: Failed to fetch http://deb.debian.org/debian/dists/stretch-updates/main/binary-amd64/Packages  Cannot initiate the connection to deb.debian.org:80 (0.0.9.199). - connect (22: Invalid argument)
E: Some index files failed to download. They have been ignored, or old ones used instead.
The command '/bin/sh -c apt-get update && apt-get install -y wget libxrender1 libfontconfig1 libmemcached-dev libz-dev libxml2-dev libmcrypt-dev mcrypt openssl zip unzip git libfreetype6-dev libjpeg62-turbo-dev libmcrypt-dev libpng12-dev libssl1.0.0 net-tools' returned a non-zero code: 100

I changed this to "RUN apt-get update" to reduce errors but it showed the same errors. Please help me with any ideas or advice. :)