When I try to add firebase push notification in the android studio then it shows an error

When I try to add firebase push notification in the android studio then it shows an error.

Manifest merger failed : uses-sdk:minSdkVersion 15 cannot be smaller than version 16 declared in library [com.google.firebase:firebase-iid:19.0.0] C:\Users\golam\.gradle\caches\transforms-2\files-2.1\856a947c1a9c6ebc4d2fc0c2fb4dbece\firebase-iid-19.0.0\AndroidManifest.xml as the library might be using APIs not available in 15
    Suggestion: use a compatible library with a minSdk of at most 15,
        or increase this project's minSdk version to at least 16,
        or use tools:overrideLibrary="com.google.firebase.iid" to force usage (may lead to runtime failures)

2 answers

  • answered 2019-08-24 00:06 Hasnain Sabir

    firebase library com.google.firebase:firebase-iid:19.0.0 is supported minimum uses-sdk:minSdkVersion 16 but your log shows you have 15 so wou need to change the minsdk level from 15 to 16 or use the library which support the uses-sdk:minSdkVersion 15

  • answered 2019-08-24 00:18 Achref ArShavin

    Just downgrade your firebase version or upgrade your min sdk to 16 instead of 15