How do you check what version of Presto you are using?

Postgres has:

SELECT VERSION();

What is the Presto equivalent?

I've taken a look through Presto docs, but was not able to find an equivalent.

1 answer

  • answered 2019-10-01 20:58 kokosing

    Have you tried the below?

    SELECT version FROM system.runtime.nodes;
    

    I tested on Presto 319 and Starburst Presto 312-e, but should work with pretty any Presto version.