rtmp can be played by ffplay, but video.js not

I just run

ffprobe -show_frames -i rtmp://127.0.0.1:1935/live/0

and I got:

ffprobe version 4.1 Copyright (c) 2007-2018 the FFmpeg developers
  built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.10) 20160609
  configuration: --enable-shared --enable-libx264 --enable-sdl --enable-gpl
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
  libpostproc    55.  3.100 / 55.  3.100
[h264 @ 0xf5e400] Invalid NAL unit 0, skipping.
    Last message repeated 13 times
[H264 Decoder @ 0xfb4e40] Broken frame packetizing
[h264 @ 0xf5e400] top block unavailable for requested intra mode
[h264 @ 0xf5e400] error while decoding MB 112 0
[H264 Decoder @ 0xfb4e40] Broken frame packetizing
[h264 @ 0xf5e400] illegal short term buffer state detected
[h264 @ 0xf5e400] negative number of zero coeffs at 111 0
[h264 @ 0xf5e400] error while decoding MB 111 0
[H264 Decoder @ 0xfb4e40] Broken frame packetizing
[h264 @ 0xf5e400] illegal short term buffer state detected
[h264 @ 0xf5e400] Frame num change from 0 to 1
[h264 @ 0xf5e400] decode_slice_header error
[h264 @ 0xf5e400] Frame num change from 0 to 2
[h264 @ 0xf5e400] decode_slice_header error
[h264 @ 0xf5e400] illegal short term buffer state detected
[H264 Decoder @ 0xfb4e40] Broken frame packetizing
[h264 @ 0xf5e400] illegal short term buffer state detected
[h264 @ 0xf5e400] Invalid NAL unit 8, skipping.
    Last message repeated 1 times
[h264 @ 0xf5e400] Frame num change from 0 to 1
[h264 @ 0xf5e400] decode_slice_header error
[H264 Decoder @ 0xfb4e40] Broken frame packetizing
[h264 @ 0xf5e400] Frame num change from 0 to 1
[h264 @ 0xf5e400] decode_slice_header error
[h264 @ 0xf5e400] Frame num change from 0 to 1
[h264 @ 0xf5e400] decode_slice_header error
[h264 @ 0xf5e400] concealing 3282 DC, 3282 AC, 3282 MV errors in I frame
[h264 @ 0xf5e400] illegal short term buffer state detected
[h264 @ 0xf5e400] Frame num change from 1 to 2
[h264 @ 0xf5e400] decode_slice_header error
    Last message repeated 1 times
[h264 @ 0xf5e400] Frame num change from 1 to 2
[h264 @ 0xf5e400] decode_slice_header error
    Last message repeated 1 times
[h264 @ 0xf5e400] Frame num change from 1 to 2
[h264 @ 0xf5e400] decode_slice_header error
    Last message repeated 2 times
[h264 @ 0xf5e400] Frame num change from 2 to 3
[h264 @ 0xf5e400] decode_slice_header error
    Last message repeated 1 times

It can be played with ffplay, but in video.js, it shows FLASH: rtmpconnectfailure; I googled the message Frame num change from but didn't get useful information, so how can I debug this and find a solution? Any help would be appreciated, thank you!