Not able to install packages with pip3 in python3 [ERROR: Could not find a version that satisfies the requirement]

I tried to install some python3 packages using pip3, but after typing

pip3 install <package_name>

Terminal displays: ERROR: Could not find a version that satisfies the requirement package_name (from versions: none) ERROR: No matching distribution found for package_name.

I've been searching for some similar issues in StackOverflow, but after reading Not able to install Python packages [SSL: TLSV1_ALERT_PROTOCOL_VERSION] and 'pip install' fails for every package ("Could not find a version that satisfies the requirement") , I tried those possible solutions (basically upgrading pip3: 'curl https://bootstrap.pypa.io/get-pip.py | python3') , but the problem is still remaining. I tried it with pip and pip3; I updated setuptools too; I also upgraded OpenSSL. Nothing changed.

I don't know if it has anything to do with OpenSSL (I'm using macOs Mojave), but I tried and I don't know how to solve it. Anyone?

Thanks.