'stack level too deep (SystemStackError)' when running a locally built gem

I checked out this repo https://github.com/cmedley/terraforming and tried to build it locally.

I ran the following

bundle install
rake build
gem install pkg/terraforming.gem

Then when I ran terraforming in the shell I got the error message:

$ /usr/local/bin/terraforming
/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/requirement.rb:100:in `=~': stack level too deep (SystemStackError)
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/requirement.rb:100:in `parse'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/requirement.rb:131:in `block in initialize'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/requirement.rb:131:in `map!'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/requirement.rb:131:in `initialize'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/requirement.rb:59:in `new'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/requirement.rb:59:in `create'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/dependency.rb:59:in `initialize'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems.rb:233:in `new'
     ... 8574 levels...
    from /Library/Ruby/Gems/2.3.0/gems/terraforming-0.17.1.pre.local/bin/terraforming:22:in `load'
    from /Library/Ruby/Gems/2.3.0/gems/terraforming-0.17.1.pre.local/bin/terraforming:22:in `<top (required)>'
    from /usr/local/bin/terraforming:22:in `load'
    from /usr/local/bin/terraforming:22:in `<main>'

I have no ruby experience and I only want to run this utility to fix an one-off issue. I would appreciate simple step by step instructions to resolve this issue, not a load of links to 'understand' the ruby ecosystem.

Ruby version: ruby 2.3.7p456 (2018-03-28 revision 63024) [universal.x86_64-darwin18]