IntelliJ Idea Not showing GUI

For some reason my GUI is no longer showing up on the .form file, instead it is all the hard code for it like:

<?xml version="1.0" encoding="UTF-8"?>
<form xmlns="http://www.intellij.com/uidesigner/form/" version="1" bind-to-class="emroGUI">
  <grid id="27dc6" binding="mainPanel" layout-manager="GridLayoutManager" row-count="11" column-count="7" same-size-horizontally="false" same-size-vertically="false" hgap="-1" vgap="-1">
    <margin top="0" left="0" bottom="0" right="0"/>
    <constraints>
      <xy x="20" y="20" width="742" height="400"/>
    </constraints>
    <properties/>
    <border type="none"/>

etc. When I originally made the GUI I did it via 'drag and drop' and I saw the actual GUI form. How do I get the actual form back?

1 answer

  • answered 2020-01-18 06:35 Saeed Alizadeh

    your XML content malformed now and I think you are missing following ending tags:

     </grid> </form>
    

    accurate structure is as following:

    <?xml version="1.0" encoding="UTF-8"?>
    <form xmlns="http://www.intellij.com/uidesigner/form/" version="1" bind-to-class="emroGUI">
        <grid id="27dc6" binding="mainPanel" layout-manager="GridLayoutManager" row-count="11" column-count="7" same-size-horizontally="false" same-size-vertically="false" hgap="-1" vgap="-1">
            <margin top="0" left="0" bottom="0" right="0"/>
            <constraints>
                <xy x="20" y="20" width="742" height="400"/>
            </constraints>
            <properties/>
            <border type="none"/>
        </grid>
    </form>