psycopg2-2.8.5-cp38-cp38-win_amd64.whl is not a supported wheel on this platform

I tried to run pip install psycopg2-2.8.5-cp38-cp38-win_amd64.whl, got this error: psycopg2-2.8.5-cp38-cp38-win_amd64.whl is not a supported wheel on this platform.

My python version and bit : Python 3.8.2 (tags/v3.8.2:7b3ab59, Feb 25 2020, 23:03:10) [MSC v.1916 64 bit (AMD64)] on win32

Also tried to install win32 file still same : pip install psycopg2-2.8.5-cp38-cp38-win32.whl psycopg2-2.8.5-cp38-cp38-win32.whl is not a supported wheel on this platform.

Thanks in advance to the helpers :))

btw these are the versions tried some of them too:

psycopg2‑2.8.5‑cp39‑cp39‑win_amd64.whl psycopg2‑2.8.5‑cp39‑cp39‑win32.whl psycopg2‑2.8.5‑cp38‑cp38‑win_amd64.whl psycopg2‑2.8.5‑cp38‑cp38‑win32.whl psycopg2‑2.8.5‑cp37‑cp37m‑win_amd64.whl psycopg2‑2.8.5‑cp37‑cp37m‑win32.whl psycopg2‑2.8.5‑cp36‑cp36m‑win_amd64.whl psycopg2‑2.8.5‑cp36‑cp36m‑win32.whl psycopg2‑2.8.4‑cp35‑cp35m‑win_amd64.whl psycopg2‑2.8.4‑cp35‑cp35m‑win32.whl psycopg2‑2.8.4‑cp27‑cp27m‑win_amd64.whl psycopg2‑2.8.4‑cp27‑cp27m‑win32.whl psycopg2‑2.7.7‑cp34‑cp34m‑win_amd64.whl psycopg2‑2.7.7‑cp34‑cp34m‑win32.whl