JavaFX-11 and VSCode

enter image description hereHi I have tried to set up vscode for javafx11, I first had jdk 14 so I reverted to jdk 11, then I installed javafx jdk 11 from the website. I added the jar files to the referenced libraries. Then I tried to make sure the environment variables were correct, I tried to set the classpath using powershell in vscode. I am getting this error

Error: LinkageError occurred while loading main class HelloJavaFX java.lang.UnsupportedClassVersionError: HelloJavaFX (class file version 58.65535) was compiled with preview features that are unsupported. This version of the Java Runtime only recognizes preview features for class file version 55.65535

I tried to change the launch.json file but I dont know json. It doesnt let me post it here.. Ive included a picture if that works.. Thanks