Offline install of cryptography package fails

I'm trying to install offline the following dependencies : requests and Office365-REST-Python-Client in my production environnement.

I downloaded zipped packages using :

pip download - r requests.txt

I got the following .whl

enter image description here

When I try to run the install on the production server with the following command :

pip3 install -r /dumy_path/wheels/requirements.txt --no-index --find-links file:///dumy_path/wheels

I get the following error for the crypto package:

Collecting Office365-REST-Python-Client==2.3.2 (from -r /dumy_path/wheels/requirements.txt (line 1))

Collecting requests (from -r /dumy_path/wheels/requirements.txt (line 2))

Collecting msal (from Office365-REST-Python-Client==2.3.2->-r /dumy_path/wheels/requirements.txt (line 1))

Collecting idna<3,>=2.5 (from requests->-r /dumy_path/wheels/requirements.txt (line 2))

Collecting urllib3<1.27,>=1.21.1 (from requests->-r /dumy_path/wheels/requirements.txt (line 2))

Collecting certifi>=2017.4.17 (from requests->-r /dumy_path/wheels/requirements.txt (line 2))

Collecting chardet<5,>=3.0.2 (from requests->-r /dumy_path/wheels/requirements.txt (line 2))

Collecting PyJWT[crypto]<3,>=1.0.0 (from msal->Office365-REST-Python-Client==2.3.2->-r /dumy_path/wheels/requirements.txt (line 1))

Collecting cryptography<4,>=0.6 (from msal->Office365-REST-Python-Client==2.3.2->-r /dumy_path/wheels/requirements.txt (line 1))

  Could not find a version that satisfies the requirement cryptography<4,>=0.6 (from msal->Office365-REST-Python-Client==2.3.2->-r /dumy_path/wheels/requirements.txt (line 1)) (from versions: )

No matching distribution found for cryptography<4,>=0.6 (from msal->Office365-REST-Python-Client==2.3.2->-r /dumy_path/wheels/requirements.txt (line 1))

Production environnement is Redhat 7.9 and dev environnement is Fedora Workstation 33 How can I fix this ? Thanks