How to set the minimum required .NET framework version for my Nuget?

I am exposing several (Framework) class libraries through Nuget to my main application. I recently updated my main application to .NET 4.7.2 whereas my Nugets are still in .NET 4.5.2.

Surprisingly I am able to install these Nugets into my 4.7.2 application. I would expect this to be blocked as I am (at least that is what I thought) explicitly targeting .NET 4.5.2 in my Nuspec file:

  <files>
    <file src="bin\$configuration$\$id$.pdb" target="lib\net452\" />
  </files>

NuGet Package Manager does not show the minimum .NET version: enter image description here