package install issues after upgrading pip to 21.1.1

After upgrading pip to 21.1.1, when trying to install some private packages getting the following errors: (I tried using pip 20.2.3 and it works fine. Any idea on how I can get it resolved.)

ERROR: Could not find a version that satisfies the requirement private-package-name (unavailable) (from versions: none)

ERROR: No matching distribution found for private-package-name (unavailable)