Can't update Firebase Tools - protobufjs error

Every so often npm reminds me to update firebase-tools but I get the error below when attempting to do so.

npm ERR! code 1
npm ERR! path /root/.nvm/versions/node/v10.24.0/lib/node_modules/firebase-tools/node_modules/protobufjs
npm ERR! command failed
npm ERR! command sh -c node scripts/postinstall
npm ERR! internal/modules/cjs/loader.js:638
npm ERR!     throw err;
npm ERR!     ^
npm ERR! 
npm ERR! Error: Cannot find module '/root/.nvm/versions/node/v10.24.0/lib/node_modules/firebase-tools/node_modules/protobufjs/scripts/postinstall'
npm ERR!     at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
npm ERR!     at Function.Module._load (internal/modules/cjs/loader.js:562:25)
npm ERR!     at Function.Module.runMain (internal/modules/cjs/loader.js:831:12)
npm ERR!     at startup (internal/bootstrap/node.js:283:19)
npm ERR!     at bootstrapNodeJSCore (internal/bootstrap/node.js:623:3)

As you can see, I am running Node v10.24.0. I am able to deploy my Firebase projects with things as they are. Upgrading Node might be a solution but I am concerned that upgrading to say, Node 12, will break something, so I'd rather not.

Is there another solution?

And, is there actually a problem, or am I missing some functionality, by continuing to use firebase-tools v7.23.0?

How many English words
do you know?
Test your English vocabulary size, and measure
how many words do you know
Online Test
Powered by Examplum