Error getting the correct Python3 dependency

I get this error when trying to install HTCondor on Amazon Linux 2 instance:

Error: Package: python3-condor-8.8.15-1.el7.x86_64 (htcondor-stable)
       Requires: libpython3.6m.so.1.0()(64bit)

I tried installing python 3.6 on my own (given that the one installed was 3.7) and in /usr/local/lib I have libpython3.6m.so.1.0. Is this the same as libpython3.6m.so.1.0()(64bit)?

Adding it to the LD Library Path (export LD_LIBRARY_PATH=/usr/local/lib/) doesn't seem to work.

How many English words
do you know?
Test your English vocabulary size, and measure
how many words do you know
Online Test
Powered by Examplum