Conda environment missing dependencies when trying to download THOR tracker

I am new to linux in general and I've recently got into vision coding. I am trying to download the THOR real time tracker from https://github.com/xl-sr/THOR.

While trying to make the conda environment I have got a missing dependencies error:

~/Downloads/THOR$ conda env create -f environment.yml
Solving environment: failed

ResolvePackageNotFound: 
  - ca-certificates==2019.1.23=0
  - freetype==2.9.1=h8a8886c_1
  - ninja==1.9.0=py37hfd86e86_0
  - openssl==1.1.1c=h7b6447c_1
  - libgcc-ng==8.2.0=hdf63c60_1
  - mkl==2019.4=243
  - readline==7.0=h7b6447c_5
  - libstdcxx-ng==8.2.0=hdf63c60_1
  - cudatoolkit==10.0.130=0
  - mkl_random==1.0.2=py37hd81dba3_0
  - olefile==0.46=py37_0
  - six==1.12.0=py37_0
  - pytorch==1.1.0=py3.7_cuda10.0.130_cudnn7.5.1_0
  - mkl_fft==1.0.12=py37ha843d7b_0
  - intel-openmp==2019.4=243
  - libffi==3.2.1=hd88cf55_4
  - cffi==1.12.3=py37h2e261b9_0
  - zstd==1.3.7=h0b5b093_0
  - numpy-base==1.16.4=py37hde5b4d6_0
  - sqlite==3.28.0=h7b6447c_0
  - python==3.7.3=h0371630_0
  - jpeg==9b=h024ee3a_2
  - torchvision==0.3.0=py37_cu10.0.130_1
  - pillow==6.0.0=py37h34e0f95_0
  - libpng==1.6.37=hbc83047_0
  - ncurses==6.1=he6710b0_1
  - libedit==3.1.20181209=hc058e9b_0
  - libgfortran-ng==7.3.0=hdf63c60_0
  - libtiff==4.0.10=h2733197_2
  - zlib==1.2.11=h7b6447c_3
  - xz==5.2.4=h14c3975_4
  - numpy==1.16.4=py37h7e9f1db_0
  - blas==1.0=mkl

I have tried downloading a few of them with sudo install, pip or conda but the required version is not found or the package at all. The tracker is from 2019 and I do not think it has been updated since, but this is the best real time tracker I have found that does not require recognition and training which is exactly what I am looking for. I would appreciate any help or suggestions for other trackers that use GPU and do not need training and recognition.

How many English words
do you know?
Test your English vocabulary size, and measure
how many words do you know
Online Test
Powered by Examplum