React Native Podfile pod install throw npm error

Hey i work my own project. When i run pod install it throw npm erorr. I use React Native CLi. I look many question but i don't fix my issue I tried every way. if not again delete xcode and install

İnfo:

**

>  CocoaPods : 1.11.2
    >             Ruby : ruby 2.6.8p205 (2021-07-07 revision 67951) [universal.arm64e-darwin21]
    >         RubyGems : 3.0.3.1
    >             Host : macOS 12.0.1 (21A559)
    >            Xcode : 13.2.1 (13C100)
    >              Git : git version 2.32.0 (Apple Git-132)
    >     Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib
    >     Repositories : cocoapods - git - https://github.com/CocoaPods/Specs.git @
    > 5c2d076a5230a80111142e985079735d97f41230

**

Here is my podfile:

# Uncomment the next line to define a global platform for your project
platform :ios, '9.0'

target 'RezervePlus' do
  # Comment the next line if you don't want to use dynamic frameworks
  use_frameworks!

  # Pods for RezervePlus

  pod 'RNCAsyncStorage', :path => '../node_modules/@react-native-async-storage/async-storage'

  target 'RezervePlusTests' do
    inherit! :search_paths
    # Pods for testing
  end

end

Error:

       Analyzing dependencies
    Downloading dependencies
    Installing RNCAsyncStorage (1.15.15)
    Installing React (0.11.0)
    [!] /bin/bash -c 
    set -e
    npm install --production
    
    npm ERR! code 1
    npm ERR! git dep preparation failed
    npm ERR! command /usr/local/bin/node /usr/local/lib/node_modules/npm/bin/npm-cli.js install --force --cache=/Users/emirhanselamet/.npm --prefer-offline=false --prefer-online=false --offline=false --no-progress --no-save --no-audit --include=dev --include=peer --include=optional --no-package-lock-only --no-dry-run
    npm ERR! npm WARN using --force Recommended protections disabled.
    npm ERR! npm WARN deprecated deflate-crc32-stream@0.1.2: module has been merged into crc32-stream
    npm ERR! npm WARN deprecated source-map-url@0.4.1: See https://github.com/lydell/source-map-url#deprecated
    npm ERR! npm WARN deprecated grunt-jest@0.1.3: No longer maintained. Try grunt-run instead
    npm ERR! npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
    npm ERR! npm WARN deprecated sprintf@0.1.5: The sprintf package is deprecated in favor of sprintf-js.
    npm ERR! npm WARN deprecated har-validator@5.1.5: this library is no longer supported
    npm ERR! npm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
    npm ERR! npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    npm ERR! npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
    npm ERR! npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    npm ERR! npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    npm ERR! npm WARN deprecated cryptiles@0.2.2: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
    npm ERR! npm WARN deprecated cryptiles@0.2.2: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
    npm ERR! npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
   

Please help.

How many English words
do you know?
Test your English vocabulary size, and measure
how many words do you know
Online Test
Powered by Examplum