"URL-safe CSRF tokens are now the default" warning

I have recently upgraded from Rails 6 to 7 and even though I have urlsafe_csrf_tokens set to true:

config/initializers/new_framework_defaults_6_1.rb

Rails.application.config.action_controller.urlsafe_csrf_tokens = true

when I start the application I keep getting the following warning:

DEPRECATION WARNING: URL-safe CSRF tokens are now the default. Use 6.1 defaults or above.

I would like to understand why?

How many English words
do you know?
Test your English vocabulary size, and measure
how many words do you know
Online Test
Powered by Examplum