Error when scheduling refresh for Python script in Power BI

Hope to get some advice with Power BI schedule refershing Python script.

I can run the Python script in Power BI successfully. I am using Anaconda environment and I do have issue before when running it directly in Power BI Python script. However, after following the artile, How to Get Started Using Python using Anaconda, VS Code, Power BI and SQL Server, which I find oneline, it now works. I can run the script in Power BI Desktop successfully. The problem now is that when I try to automate the Python script using schedule refresh Gateway Personal mode connection, it pops up error again. Please see below for details. I am using personal gateway. I cannot find a solution online. Could anyone let me know what is wrong with it? Thanks!

Failed to update data source credentials: ADO.NET: Python script error. C:\Users\becky.lam\Anaconda3\lib\site-packages\numpy_init_.py:143: UserWarning: mkl-service package failed to import, therefore Intel(R) MKL initialization ensuring its correct out-of-the box operation under condition when Gnu OpenMP had already been loaded by Python process is not assured. Please install mkl-service package, see http://github.com/IntelPython/mkl-service from . import distributor_init Traceback (most recent call last): File "C:\Users\becky.lam\PythonScriptWrapper_a418e530-37dc-4b01-9ce1-9ef57887a15a\PythonScriptWrapper.PY", line 2, in import os, pandas, matplotlib File "C:\Users\becky.lam\Anaconda3\lib\site-packages\pandas_init.py", line 16, in raise ImportError( ImportError: Unable to import required dependencies: numpy: IMPORTANT: PLEASE READ THIS FOR ADVICE ON HOW TO SOLVE THIS ISSUE! Importing the numpy C-extensions failed. This error can happen for many reasons, often due to issues with your setup or how NumPy was installed. We have compiled some common reasons and troubleshooting tips at: Please note and check the following: * The Python version is: Python3.9 from "C:\Users\becky.lam\Anaconda3\python.exe" * The NumPy version is: "1.20.3" and make sure that they are the versions you expect. Please carefully study the documentation linked above for further help. Original error was: DLL load failed while importing _multiarray_umath: The specified module could not be found. Hide details

How many English words
do you know?
Test your English vocabulary size, and measure
how many words do you know
Online Test
Powered by Examplum